Learning the Interface
Unity Manual > User Guide > Unity Basics > Learning the Interface

Learning the Interface

First Launch

При первом запуске Unity вы увидите следующее:

По умолчанию, при первом запуске Unity открывается сцена Islands проекта Tropical Paradise.

Главное окно редактора состоит из снабжённых закладками частей, называемых секторами (Views). Есть несколько типов секторов, каждый со своей спецификой.

Project View

Каждый проект содержит папку Assets. Содержимое этой папки представлено в Project View. Это ресурсы игры: скрипты, 3D-модели, текстуры, аудиофайлы, префабы (Prefabs). Можно открыть папку, содержащую ресурс через стандартный Проводник Windows, щёлкнув правой кнопкой мыши по нему и выбрав Reveal in Exlorer.

Замечание: при перемещении ресурсов внешними инструментами (например, Проводником) будут потеряны все метаданные, связанные с ним. Метаданные хранят информацию о ресурсе и его связях с другими ресурсами. Всегда перемещайте ресурсы только в Project View.

Добавление ресурса в проект (2 способа):
* перетащить файл из Проводника в Project View.
* Assets→Import New Assets.

Ресурс будет автоматически импортирован в проект и станет доступен для использования. Подробная информация — Asset Workflow.

Сцены так же хранятся в папке Assets и отображаются в Project View. Их можно считать отдельными уровнями. К примеру, сцена Islands загружается при первом запуске Unity.
Создание сцены: File→New Scene (Ctrl+N). Сохранение сцены: File→Save Scene (Ctrl+S).

Некоторые ресурсы создаются непосредственно в Unity. Для этого используется выпадающее меню Create в Project View или ПКМ→Create.


Выпадающее меню Create.

Меню Create позволяет добавлять в проект скрипты, префабы, папки и прочее. Любой ресурс или папку можно переименовать: F2 или два клика по имени. Если зажать Alt, то при раскрытии директории будут раскрыты и все поддиректории.

Hierarchy


Hierarchy содержит все объекты (GameObject) открытой сцены. Некоторые из них — это экземпляры ресурсов (3D-модели и прочее), другие — экземпляры префабов. В Hierarchy объектам можно задавать наследования. Объекты, добавляемые в сцену или удаляемые из неё, отображаются или наоборот перестают отображаться в Hierarchy.

Parenting

Unity использует концепцию наследования (Parenting). Любой объект может быть дочерним по отношению к другому. Для этого достаточно перетащить его на «родителя» в Hierarchy. Дочерний объект будет двигаться и вращаться вместе с родителем.


Два независимых объекта.

Один объект является дочерним.

Более подробная информация о наследовании дана в секции Parenting в Transform Component.

Toolbar

Панель инструментов (Toolbar) состоит из пяти базовых групп инструментов. Каждая группа отвечает за свой участок редактора.

Transform Tools — инструменты трансформации объектов, используются в Scene View.
Transform Gizmo Toggles — инструменты для работы с гизмо-контейнером, используются в Scene View.
Play/Pause/Step Buttons — инструменты предпросмотра игры, используются в Game View.
Layers Drop-down — определяет, какие объекты будут отображаться в Scene View.
Layout Drop-down — определяет взаимное расположение секторов окна.

Scene View


Scene View.

Scene View используется для позиционирования объектов (окружение, персонажи, камеры, системы частиц и прочее).

Вот некоторые приёмы работы в Scene View:
* Зажатый ПКМ активирует режим свободного полёта.
* Перемещаться можно клавишами WASD на манер FPS.
* Выберите объект и нажмите F. Scene View будет центрирован и масштабирован по объекту.
* При зажатом Alt, ЛКМ будет крутить камеру вокруг текущей точки опоры.
* При зажатом Alt, СКМ будет перемещать камеру.
* При зажатом Alt, ПКМ будет масштабировать Scene View.
* Альтернативный режим перемещений (весьма удобен) — клавиша Q.

Positioning GameObjects

Для размещения объектов в игровом мире используются инструменты группы Transform Tools: Translate, Rotate и Scale. Каждый объект имеет контейнер гизмо, описанный вокруг него. Манипулировать объектами можно используя «ручки» гизмо или вводя числовые значения в соответствующие свойства компонента Transform в Inspecor View.


* Зажатый Alt при перемещении гизмо активирует привязку в соответствии с настройками Snap Settings ( Edit→Snap Settings...).
* Центр гизмо позволяет перемещать его по всем осям одновременно.
* Зажатый Ctrl при перемещении гизмо активирует привязку к пересечениям с коллайдерами.
* СКМ позволяет перемещать гизмо по подсвеченной в данный момент оси без нажатия на эту ось
* Нужно быть осторожным с масштабированием, особенно неравномерным (например 1, 2, 1), так как это непредсказуемо влияет на дочерние объекты.

Подробная информация о трансформации объектов — Transform Component.

Gizmo Display Toggles используется для задания позиции гизмо.


Gizmo Display Toggles
Position:
* Center
размещает гизмо в центре визуализируемого объекта.
* Pivot размещает гизмо на точке опоры меша.
Rotation:
* Local поворачивает гизмо параллельно осям локальной системы координат объекта.
* Global поворачивает гизмо параллельно осям мировой системы координат.

Scene Gizmo

В верхнем правом угру Scene View располагается Scene Gizmo. Он обозначает положение камеры сцены и позволяет быстро изменять ракурс обзора. Нажатие на ручки Scene Gizmo перемещает камеру в соответствующую позицию (вид сверху, слева, спереди и т. д.) или включает изометрический режим (Isometric Mode). Включение/выключение изометрического режима — Shift+СКМ по Scene Gizmo.


Режим перспективы (Perspective mode).

Режим изометрии (Isometric mode). Нет перспективных искажений — видимый размер объектов не зависит от расстояния.

Scene View Control Bar


Первое выпадающее меню позволяет выбрать режим отрисовки (Draw Mode) Scene View. Варианты: текстурированные объекты (Textured), каркасная сетка (Wireframe) и комбинированный вариант (Textured with Wireframe overlay).


Draw Mode.

Следующее выпадающее меню позволяет выбрать режим анализа рендеринга (Render Modes) в Scene View. Варианты: полноцветный просмотр(RGB), показ альфаканалов (Alpha), показ перекрытий (Overdraw) и анализ текстур (Mipmaps).


Render Mode.
* RGB рисует сцену в полноцветном (нормальном) режиме.
* Alpha отрисовывает альфа-канал (он отвечает за частичную прозрачность).
* Overdraw показывает оранжевым цветом области сцены, в которых объекты перекрывают друг друга. Если в одном месте скопилось много объектов которые заслоняют собой друг друга или другие объекты на заднем плане, то эта область высветится оранжевым цветом. Этот режим помогает оптимизировать сцену и избавляться от ненужных (попросту неиспользуемых) элементов.
* Mipmaps показывает отклонения размера (разрешения) текстур от предполагаемого идеального. Красным цветом подкрашиваются слишком большие текстуры, синим — слишком маленькие.

Далее идут две кнопки: Scene Lighting and Game Overlay.

Включение Scene Lighting заменит освещение сцены стандартными ИС на освещение её ИС, размещёнными пользователем. Game Overlay включает отображение в сцене элементов вроде неба (Skyboxes) и интерфейса (GUI Elements).

Game View


The Game View is rendered from the Camera(s) in your game. It is representative of your final, published game. You will need to use one or more Cameras to control what the player actually sees when they are playing your game. For more information about Cameras, please view the Camera Component page.

Game View — рендер из игровой камеры, предпросмотр игры. Можно использовать одну кмеру или больше.
Подробности о камерах в справке — Camera Component.

Play Mode

Три кнопки отвечают за управление предпросмотром игры. Play, Pause и Step.
Все изменения, произведённые во время предпросмотра, сбрасываются при выходе из него. Исключением являются изменения в префабах.

Game View Control Bar

Первое выпадающее меню в Game View — это контроль пропорций изображения (Aspect Drop-down). На некоторых дисплеях это соотношение отличается от стандартного 4:3 (например, на широкоформатных мониторах — 16:10).

Далее идёт кнопка Maximize on Play. Если она нажата, то Game View растягивается на всё окна редактора при предпросмотре.

Кнопка Gizmos включает отображение контейнеров гизмо в Game View.

Последняя кнопка — Stats. Она показывает статистку рендеринга (Rendering Statistics), полезную при оптимизации игры.


Inspector


Объект может содержать в себе меши (meshes), скрипты (scripts), звуки, ИС (Lights) и другие элементы. Inspector отображает подробную информацию о выделенном объекте и всех прикреплённых к нему компонентах (Components), а также их свойства. Также здесь можно редактировать эти свойства.
Подробная информаци о взаимодействии объектов и компонентов — GameObject-Component relationship.

Любые свойства, отображаемые в Inspector, могут быть изменены там же. Это относится и к переменным скриптов, прикреплённых к объекту. Можно использовать Inspector для изменения переменных во время предпросмотра для экспериментов и поиска магического баланса игры. Если в скрипте определена публичная переменная объектного типа, можно перетащить объект или префаб прямо на неё в Inspector и совершить этим присвоение значения.

Нажатие на знак вопроса справа от названия компонента в Inspector вызовет страницу справки по этому компоненту.
Полная информация обо всех компонентах содержится в Component Reference.


Добавление компонентов.

Нажатие на иконку шестерёнки или правый клик по имени компонента вызовет контекстное меню компонента.

Inspector также показывает настройки импорта для выбранного ресурса.


Нажатие Apply приведёт к повторному импорту ресурса с новыми настройками.

Выпадающее меню Layer назначает выбранный объект на один из слоёв. Выпадающее меню Tag присваивает объекту тег (флаг).

Prefabs

Работа с префабами в Inspector отличается от работы с другими объектами. Подробнее о префабах можно посмотреть на страничке Prefab.

Status Bar

Строка состояния (Status Bar) расположена в нижней части окна редактора. Она отображает ошибки компиляции и логи дебагга. Если возникают проблемы с игрой, стоит заглянуть в строку состояния. Двойное нажатие на неё вызовет окно консоли (Console), в котором отображаются все ошибки.

Console

Двойное нажатие на ошибку в строке состояния или команда Window→Console вызовет консоль.

Консоль показывает сообщения, предупреждения и ошибка, а так же логи дебага. Можно посылать собственные сообщения в консоль, используя функции Debug.Log() и Debug.Error(). Двойной клик по сообщению или ошибке откроет скрипт, при выполнении которого они возникли.

Консоль имеет некоторые настройки.

Большая часть настроек понятна сама собой, но нужно дать пояснения по опции Error Pause. Пауза вызывается только при Debug.Error(), но не при Debug.Log().

Customizing Your Workspace

Можно настраивать расположение ( Layout) секторов, перетаскивая их за закладки. Если перетащить закладку в область закладок уже существующего окна, то она будет добавлена к присутствующим там закладкам. Также можно прикрепить сектор к краю экрана или краю другого сектора.


Сектор может быть пристыкован к одной из сторон существующего окна.

Закладки могут открепляться от главного окна редактора и включаться в состав плавающего окна редактора. Плавающее окно может содержать сектора и закладки так же, как и главное окно.


Плавающее окно редактор похоже на главное окно, но не имеет панели инстурментов (Toolbar).

Когда расположение секторов задано, его можно сохранить и загрузить в нужный момент через выпадающее меню Layout (Save и Load).


Полностью настроенное расположение секторов.

В любое время можно правым кликом по закладке вызвать меню с дополнительными возможостями, такими как максимизация сектора или добавление новых закладок.